Quick test of the CommLite EF to NEX lens adapter. CN-EF-NEX

commlite-300x300 Quick test of the CommLite EF to NEX lens adapter. CN-EF-NEX
Commlite full frame EF to NEX lens mount adapter.

My old Metabones MK1 adapter is not suitable for full frame lenses on the new Sony A7s. So in anticipation of the arrival of my A7s I ordered a cheap CommLite full frame autofocus ready adapter on ebay. This adapter (CN-EF-NEX) was only $90 USD so I thought I would give it a try, much cheaper than the metabones.

To be honest I wasn’t expecting much, but now I have the adapter in my hands I am pleasantly surprised. It appears well made and very solid. It even carries a CE mark. It works just fine on my NEX5N and FS700. On the NEX5N I have working autofocus. If the lens has image stabilisation this works too. I have tried a wide variety of Sigma and Tamron Canon EF lenses with it and they all work. Even my new Tamron 16-300mm works with this adapter, this lens doesn’t work with a number of other adapter.

Autofocus is a little slow, especially if the light is bad. Having not used the MK3 Metabones I don’t know how this compares but certainly this adapter works and is quite useable. It’s said to be compatible with full frame lenses on the A7, but as yet I have not been able to test this. The little mounting post is easily and quickly removable, but a real boon on the NEX5N with bigger lenses. For the price, you can’t go far wrong, really quite impressed considering how little it cost.

24 thoughts on “Quick test of the CommLite EF to NEX lens adapter. CN-EF-NEX”

  1. Hello Alister,
    Glad to hear the CommLite adapter works with the Sigma and Tokina lenses. Would you believe it’ll also work with the Zeiss ZE primes? I will be happy if just the aperture can be controlled … I was thinking to order one but a little skeptical so far …

  2. Hi Alister!
    Just a short question. I have a FS700 + Tamron 16-300 combined with Metabones Adapter (MarkII) … this combination does not work (aperture cant be changed). So it is possible with this 99 $ adapter? Thank

  3. Hi Alister,

    I’m hoping you will give us a full review of the A7s soon. I’d love to know what you think about it. (good and bad)

    I just got mine 3 days and I’m completely shocked about how good it is.

    I specifically would love to hear your take on “dynamic range” and it’s 8 bit implementation of S-LOG 2.

    Keep up the great work!

  4. Hi Alister

    I just got this adapter for my A7s and could not get it to activate image stabilization on those lenses that normally supported it. It did drive the IS on my FS700, but there were other problems like lack of autofocus and auto iris (error message from FS700). Have you tried out the Commlite with the A7s and image stabilized lenses? My older metabones with the A7s does activate the IS on these lenses with some quirks. I have heard it does support IS so I ordered a replacement, hoping this was just a bad copy, here are my testing results:
    —-
    FS700: Note: FS700 generic error message (ErrMsg) on some functions:“Cannot execute functions because of the condition of the lens”

    Using Sony E-Mount 18-200 zoom:

    IS: OK; AutoIris: OK; AutoFocus: OK

    Using Commlite (note: in all cases Manual Aperture worked ok)

    Canon 17-55 EF-S 2.8: IS: OK; AutoIris: ErrMsg; AutoFocus: ErrMsg
    Canon 24-105 L 4.0: IS: NG; AutoIris: ErrMsg; AutoFocus: ErrMsg (note: this lens it seems AF isn’t working at all even on Canon C100 body)
    Canon 18-135mm: IS: OK; AutoIris: ErrMsg; AutoFocus: ErrMsg; Note: This lens cannot manually focus with this adapter
    Tamron 28-300: IS: OK; AutoIris: ErrMsg; AutoFocus: ErrMsg;

    Using Metabones V2

    Canon 17-55 EF-S 2.8: IS: OK; AutoIris: OK; AutoFocus: OK
    Canon 24-105 L 4.0: IS: OK; AutoIris: OK; AutoFocus: NG (note: this lens it seems AF isn’t working at all even on Canon C100 body)
    Canon 18-135mm: IS: OK; AutoIris: OK; AutoFocus: NG; Note: Manual Focus OK
    Tamron 28-300: IS: OK; AutoIris: OK; AutoFocus: NG;

    Using Metabones Speedbooster (v1?)

    Canon 24-105 L 4.0: IS: OK; AutoIris: ErrMsg; AutoFocus: ErrMsg(note: this lens it seems AF isn’t working at all even on Canon C100 body)
    Tamron 28-300: IS: OK; AutoIris: OK; AutoFocus: ErrMsg

    A7s Results

    Using Commlite (note: in all cases Manual Aperture worked ok)

    Canon 17-55 EF-S 2.8: IS: NG; AutoIris: OK; AutoFocus: OK (though it tries it doesn’t really autofocus)
    Canon 24-105 L 4.0: IS: NG; AutoIris: OK; AutoFocus: OK
    Canon 18-135mm: IS: NG; AutoIris: OK; AutoFocus: OK; Note: This lens manually focuses but requires a lot of spinning with this adapter
    Tamron 28-300: IS: NG; AutoIris: OK; AutoFocus: OK;

    Using Metabones V2

    Canon 17-55 EF-S 2.8: IS: OK; AutoIris: OK; AutoFocus: OK (though it tries it doesn’t really autofocus)
    Canon 24-105 L 4.0: IS: OK; AutoIris: OK; AutoFocus: OK (though it tries it doesn’t really autofocus) Note: IS activates in Auto mode when half pressing shutter- in auto mode but sometimes works???
    Canon 18-135mm: IS: OK; AutoIris: OK; AutoFocus: NG; Note: Manual Focus OK
    Tamron 28-300: IS: OK; AutoIris: OK; AutoFocus: NG; Note: IS activates in Auto mode when half pressing shutter- in auto mode but sometimes works???

    Thanks much for any info! -Keith Moreau

    1. I don’t have the same lenses as you, but IS is working on the A7s with all of my lenses (mainly Sigma and Tamron). Even the brand new Tamron 16-300 works OK. IS only works when the camera is in the dedicated video mode or when the shutter button is pressed.

      1. Hi Alistair –
        Thanks so much for this resource (and your S-Log2 article on A7s, amazing). I’d really really appreciate your advice on whether above ef-nex adaptor functions with full-frame glass on the Sony A7s. I just bought the Sigma 70-200mm APO EX DG OS and my Viltrox adaptor vignette’s bad full-frame plus does not power aperture control on the lens. Big problems.

        Would love advice! Many thanks.

        1. Commlite make two versions of the adpeter, one with a round opening for APS-C cameras and one with a larger square rear aperture for full frame sensors and these don’t vignette.

  5. Hello Alister.

    I have a Sony FS7 on order and am trying to sort out my glass. Have you tried the your CommLite EF to NEX lens adapter on the Sony FS7? I’m not interested in autofocus but rather Aperture control, IS and hopefully Exif info.

    Thanks!
    Daniel Barrocas

    1. Yes, tried it today and it does work. You get full aperture control, autofocus is not great but functions and you get aperture information in the viewfinder. Have not checked to see what other lens data is making it in to the clip metadata yet.

  6. Thanks Alister! I just discovered your website. It’s a fantastic resource. Especially since I am migrating back from Canon. I’m looking forward to receiving my camera and putting it through its paces.

    Regards,
    Daniel

  7. I posted on couple of other forums , but am having lot of trouble with the 16-300. At first it was just weird with the metabones Mark IV – iris would jump when zooming . then I tried a commlite and now the Iris doesn’t work at all on either adapter. It just seems dead.

  8. Oops was rushing so much I had the wrong lens on m T2i – Correction- No T2i says error , no communication with lens – clean contacts (their fine) . So Im assuming a defective lens?

  9. Well the first 16-300 was defective and now I have a second. Doesn’t work with Metabones Mark IV at all. Does work with my Canon T2i. The Commlite is just well …weird. The iris control is just inconsistent . The iris reading in the VF often seems plain wrong and it seems to jump around a bit . I can’t get a reliable handle on it. Its too bad because I like the image and it focuses very smoothly. I like the focus behavior a lot more than the Sony 18-200, but the iris works just fine on that.
    Very disappointed.

  10. Well the first 16-300 was defective and now I have a second. Doesn’t work with Metabones Mark IV at all. Does work with my Canon T2i. The Commlite is just well …weird. The iris control is just inconsistent . The iris reading in the VF often seems plain wrong and it seems to jump around a bit . I can’t get a reliable handle on it. Its too bad because I like the image and it focuses very smoothly. I like the focus behavior a lot more than the Sony 18-200, but the iris works just fine on that.
    Very disappointed.

  11. I am planning to buy one for my Sony Nex 7, and use some Canon EF lenses. Have you heard of any problems with this match-up?
    Does the A7 have an E mount i.e. same the as the Nex 7?
    Thanks, great information on your site.

  12. I just bought a Commlite (latest version) to use with my FS700. When I attached my 16-35mm, 105mm f2.8 Macro and 70-200mm f2.8 IS 1 and try to activate autofocus I get this message “Cannot execute functions because of the condition of the lens”. Image stabilisation doesn’t activate on the 70-200 either.

    I am guessing it must be faulty but the dealer tells me autofocus won’t work on the fs700, is that correct?

Leave a Reply

Your email address will not be published. Required fields are marked *