Tag Archives: broken

Sony FX6 Intermittent Audio – Is Your Handle Secure?

DSC_0477-600x450 Sony FX6 Intermittent Audio - Is Your Handle Secure?There have been a few people popping up on various user groups and forums complaining of a sudden loss of audio or intermittent audio on their Sony FX6 cameras. A common cause of the loss of audio on the FX6 is a slightly loose top handle. The XLR inputs, MI Shoe and the cameras built in microphones are all part of the top handle, so if the handle is a little loose and the connection between the camera and handle isn’t perfect you can suddenly lose all your audio inputs.

As the connection between the handle and camera is a digital one you often won’t get any warning and if you are not wearing headphones you might not notice that you no longer have audio. Hint – wear headphones and monitor your audio when doing anything where the audio is even the slightest bit important đŸ˜‰

So it is advisable to regularly check that the thumb screws that secure the handle are tight as if done up finger tight they do have a tendency to work lose over time. The thumbscrews have sockets for an allen key and I strongly suggest you use an allen key to tighten them up, done up this way they rarely come loose.

LUT Download Issues when using Chrome – Fixed

Some of you may have been having issues downloading my LUT’s and some other content. This was occuring due to Chrome blocking the download of any files it deems unsafe. I have installed some upgraded tools on my server and you should find that downloads will work again now. Do let me know if you ever encounter issues with the site. The sooner you let me know the sooner I can look into them. Thanks.